Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 30, 2024 - 23:45 CDT
Scheduled
We will be updating software on voice servers during this time. No outages for outbound calls are expected. Brief outages for inbound calls of up to one hour may occur.
Posted Aug 30, 2024 - 12:02 CDT
This scheduled maintenance affected: Audio Path and US Inbound Calls.