Upstream carrier outtage

Incident Report for Diamond Voice

Resolved

This incident has been resolved.
Posted Feb 01, 2022 - 15:03 CST

Investigating

One of our upstream carriers is experiencing outage affecting inbound calls to local DIDs. We are working with the carrier to resolve the problem.
Posted Feb 01, 2022 - 12:20 CST