The scheduled maintenance has been completed. If you are experiencing any issues with your Diamond Voice telephone service, please contact support at 972-293-1550 and let us know as soon as possible.
Posted Sep 09, 2023 - 05:48 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2023 - 23:59 CDT
Scheduled
We will be transitioning our cloud phone service to new server equipment during this time. We expect minimal to no outage on outbound calls during this time. We expect brief outages (30 minutes or less) for inbound calls during this time. Please do not make changes to your account on the management portal during this maintenance window.
Posted Sep 08, 2023 - 13:15 CDT
This scheduled maintenance affected: Management Portal, Audio Path, and US Inbound Calls.