This outage was resolved by Spectrum as of 2:30 PM CDT 9/26/2025. If you are still experiencing any issues with your Diamond Voice service, please contact us.
Posted Sep 27, 2025 - 12:08 CDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2025 - 14:36 CDT
Investigating
We're experiencing a regional Spectrum fiber outage and are currently working to resolve.
Posted Sep 26, 2025 - 14:27 CDT
This incident affected: Management Portal, Audio Path, and US Inbound Calls.