Power Routing

Incident Report for Diamond Voice

Resolved

The electrical re-routing has been completed.
Posted Nov 14, 2025 - 06:02 CST

Investigating

Oncor is transitioning the electricity for our primary server center overnight. We not expect any interruption in service due to our backup power system.
Posted Nov 13, 2025 - 20:53 CST
This incident affected: Management Portal, Audio Path, and US Inbound Calls.